Troubleshooting playback issues

Internet Explorer

Symptom

When you try to open Verba player to listen to a conversation, an error message is shown:

TypeError: Unable to get property 'duration' of undefined or null reference

Root cause

This error is shown by the Verba JavaScript player when it is not able to identify the length of the call and the ActiveX controller is not able to load.

The ActiveX controller is not able to load when the PC/Server doesn't have an audio device assigned or the media player can't open the call's media file because it is stored in Verba Media Format.

Resolution

  • If the workstation where you are trying to listen to the call doesn't have an audio device attached, please try the playback on another machine where at least one audio device is configured.
  • If you have an audio device connected but the playback still has not started, please check the format of the media files. If the calls are recorded in the Verba Media Format, then you have to install the Verba Media Codec. Please refer to the following article: Installing Verba Unified Media Codec
  • Make sure that the Windows edition you are using contains the Windows Media Player, and Internet Explorer has the Windows Media Player plugin.
  • If you are trying to playback a video, desktop or screen share recording, but the Verba Media Codec installation is not possible, then it has to be converted to MPEG4 (.mp4) format first. Use the File Format Selection Pane on the left side of the player.

Chrome and Firefox

Make sure that the Verba Media Stream and Content Server service is activated and started on the Media Repository server. Please refer to the following article to verify the service state: Service control and activation

Please refer to the following article for playback support: Web-based media player and viewer

Symptom

When you try to open Verba player to listen to a conversation, an error message is shown, that contains a link to this article.

Root cause

This error is shown by the Verba JavaScript player when it is not able to retrieve the media file of the conversation.

In this case, the player is not able to find or connect to the Media Repository server.

A potential cause is that the media file is not uploaded to the storage.

Resolution

  • Make sure that the Firewall on the Media Repository server is turned off or an allow rule is defined for ports 10105 and 10106. (These are the ports where the Media Streamer is listening for player connections)
  • If your company is using an HTTP load balancer or HTTP proxy, make sure that these nodes are configured for session stickiness for ports 10105 and 10106 and these ports are not blocked on the components.
  • If you are trying to playback a video, desktop or screen share recording, then it has to be converted to MPEG4 (.mp4) format first. Use the File Format Selection Pane on the left side of the player.
  • Make sure that the call is covered by an upload policy.